linuxea: nginx php7.3.8 编译常见错误笔记

php7.3.8 编译常见错误

  • 依赖包
yum install gcc autoconf gcc-c++ -y
yum install libxml2 libxml2-devel openssl openssl-devel bzip2 bzip2-devel libcurl libcurl-devel libjpeg libjpeg-devel libpng libpng-devel freetype freetype-devel gmp gmp-devel readline readline-devel libxslt libxslt-devel -y 
yum install systemd-devel -y 
yum install openjpeg-devel -y
yum install -y  curl-devel 
yum install libzip libzip-devel -y
  • checking for libzip… configure: error: system libzip must be upgraded to version >= 0.11
# checking for libzip… configure: error: system libzip must be upgraded to version >= 0.11
yum remove -y libzip
wget https://nih.at/libzip/libzip-1.2.0.tar.gz
tar -zxvf libzip-1.2.0.tar.gz
cd libzip-1.2.0
./configure
make && make install
  • configure: error: off_t undefined; check your library configuration
echo '/usr/local/lib64
/usr/local/lib
/usr/lib
/usr/lib64'>>/etc/ld.so.conf
ldconfig -v
  • usr/local/include/zip.h:59:21: fatal error: zipconf.h: No such file or directory
cp /usr/local/lib/libzip/include/zipconf.h /usr/local/include/zipconf.h

编译脚本参考:

curl -Lk https://raw.githubusercontent.com/marksugar/Maops/master/php/php7/phpInstall.sh |bash -s www 7.3.8

nginx:

curl -Lk https://raw.githubusercontent.com/marksugar/Maops/master/nginx/nginxInstall.sh|bash -s www 1.16.0
1 分享

您可以选择一种方式赞助本站

支付宝扫码赞助

支付宝扫码赞助

日期: 2019-08-03分类: Nginx

标签: lnmp

发表评论